Collation conflict publishing to a file!

Topics: Database Publishing Wizard
Feb 25, 2008 at 5:01 PM
Have created a simple 1 table sql express db with vidual web developer express and tried to publish 'script to file' with the database publishing wizard.
I am getting 'an exception occured... cannot resolve collation conflict between 'latin1 etc etc'
As I am publishing to a file and not another database why is there a collation error?
Thanks
Mar 10, 2008 at 7:54 PM
i had the same problem with de collation....

My Solution was:

0.- open Visual Web Developer 2005 Express,
1.- open your Explorer Database in tools (Database Explorer) in menu View or with ctrlaltS
2.- if you dont have your database, add this with
Data Source: Database file of Microsoft SQL Server (SqlClient)
File: (Select your File from your root in IIS, example: C:\Inetpub\wwwroot\App_Data\ASPNETDB.MDF
Select Authentications
Test
3.- if you have ready your database in explorer Database, open your tree and you have the next data:
Table
View
Stored Porcedure
User Defined Function
Schema
Assembles
XML schemas Collections

4.- Open the table "aspnetApplications" and change in Properties column the Intercalation with your respective COLLATION, for example: my collation is SQLLati1GeneralCP1CIAS, ,

5.- Do this with the entire contents of the database.

6.- Open Microsoft SQL Server Management Studio Express and Select in Object Explorer: Database

7.- Click whith button right Mouse over "Database" and Select Menu "Attach.."

8.- Add your DataBase of your Website from your directory setting in IIS: for example my directory is: C:\Inetpub\wwwroot\App_Data

9.- when you have your database, do click right over your Database, for example my database was: C:\INETPUB\WWWROOT\APP_DATA\ASPNETDB.MDF , Select Properties

10.- in the windows Properties of your DataBase, Select Options and Change your Respective collation.


Note: Remember when you have connect your database in ASP.NET Editor, this not Open Properties in Microsoft SQL Server Management Studio Express. Yoy will need to Restart your DataBase Engine in MSQL Studio Express.


Mario Holod